Introduction

Quick start

Requirements and Installation

Understanding SD application development

The development cycle

Application look and feel

Security

Monetizing

Notifications

Geolocation

Timezone

Cache Management

Extensibility

Troubleshooting

Online resources

 



GeneXus X Evolution 2 Hardware and Software Requirements

See previous version

The following are the guaranteed and neccesary requirements in order to run GeneXus X Evolution 2.

GeneXus IDE needs administrator rights in order to function properly. So the user running GeneXus has to have administrator rights.

Hardware Requirements

* Processor: minimum of 1 GHz (multi core recommended).
* Memory: minimum of 2 GB of RAM (4 GB recommended).
* Hard disk: minimum of 1.2 GB of disk space for the installation. To generate applications you will need additional space or a shared disk unit to create the knowledge bases, and generate the code.

Software Requirements * Microsoft Windows Server 20XX, Microsoft Windows XP SP2, or higher.
* Microsoft .NET Framework 3.5 Service Pack 1.
* Microsoft SQL Server 2005, 2008, 2012, 2014 (Express, Standard or any other Edition). (1)
* Microsoft Internet Explorer. Minimun version: 6.0 SP1. Recommended version: 8.0 or higher.
* Sun JRE 1.6 or higher (JRE is enough, or JDK)

(1) - SQL Server 2012 is supported as of GeneXus X Evolution 2 Upgrade 1 on.
(2) - SQL Server 2014 is supported as of GeneXus X Evolution 2 Upgrade 5 on.

Generation requirements:

Generator Requirements
.NET * Microsoft .NET Framework 3.5 or higher for web environments; Microsoft .NET Framework 3.5 for win environments
   Make sure to use Xev2 Upgrade #2 or higher when using Microsoft .NET Framework 4.0
* ADO .NET provider associated to the selected DBMS

SD application check UrlRewrite common issues 
Java * Sun JDK 1.5 or higher (1)
* Servlet API implementation file for Web environments (for example servlet-api.jar file)
* Check GeneXus X Evolution 2 Java Generator for more information
Ruby * a Ruby interpreter and dependencies are distributed with GeneXus under the folder \InstallDir\gxruby\win\ruby
ruby 1.9.1p243 (2009-07-16 revision 24175)
* See Ruby Generator Requirements
Smart Devices * iOS Requirements
* BlackBerry Requirements
* Android Requirements (X Evolution 2)

(1) - JDK 1.6 or higher is needed in order to compile and execute Rest webservices (the external libraries used, as jersey-core-1.4.jar require at least JDK 1.6).

Execution requirements:

Generator Requirements
.NET * Microsoft .NET Framework 3.5 or higher for web environments; up to Microsoft .NET Framework 3.5 for win environments
   Make sure to use Xev2 Upgrade #2 or higher when using Microsoft .NET Framework 4.0
* IIS 6.0 or higher for web environments
* ADO .NET provider associated to the selected DBMS
* Check GeneXus X Evolution 2 .NET Generator for more information
Java * Sun JRE 1.5 or higher (1)
* J2EE Server or Servlet Server
* DBMS JDBC Driver
* Check GeneXus X Evolution 2 Java Generator for more information
Ruby * Webserver supporting Rack
Smart Devices * iOS Requirements
* BlackBerry Requirements
* Android Requirements (X Evolution 2)

(1) - JDK 1.6 or higher is needed in order to compile and execute Rest webservices (the external libraries used, as jersey-core-1.4.jar require at least JDK 1.6).

When generating application that uses databases, the supported DBMS's are the following:

Generator DBMS DBMS Version
.NET
Java
Visual FoxPro
Ruby(1)
* DB2 Universal Database
* DB2 UDB for iSeries
* Informix
* MySQL(2)
* Oracle
* PostgreSQL
* SQL Server
* 7.1 or higher
* V5R1 or higher
* 7.31 or higher
* 4.x or higher
* 8.1.5 or higher
* 7.x or higher
* 2000 or higher

1 - Ruby generator supports SQL Server and MySQL.
2 - Using GeneXus Access Manager and/or GXflow the supported version for Mysql is 5.0.3 or higher.

Supported Internet Browsers:

Browser Minimum Version Recommended Version
Internet Explorer Minimum version: 8.0(1) 9.0 or higher(2)
Mozilla Firefox Minimum version: 3.0 10 or higher
Google Chome Minimum version: 6.0 17 or higher
Safari Minimum version: 5.0 6.0 or higher

1 - If you are porting an application from a lower GeneXus version and keep the "HTML Document Type" version property to "do not specify"; you could use IE6. If you use Xev2 features, it is highly recommended to use up-to-date browsers; HTML5 and CSS3 browser support is needed.

2 - Internet Explorer 11 is supported since GeneXus X Evolution 2 Upgrade 4.

Before activating GeneXus Access Manager in the knowledge base, you need to install the ADO client corresponding to the DBMS where GAM database will reside.
In particular in case of Mysql database, you need to install ADO client for Mysql (libmysql.dll is required, see MySql ADO Net Configuration).

GXflow based applications require Microsoft Visual C++ 2008 Redistributable (see SAC #23847 for details).

See GeneXus X Evolution Requirements for previous versions hardware and software requirements.