Angular Generator prerequisites

Unofficial Content

For Angular applications development, your development environment should include the following:

  • Node.js
    Node.js version 8.x or 10.x. To get Node.js, go to nodejs.org. To check your version, run the following command in a terminal/console window:
    node -v

     
  • npm package manager
    For the environment setup, npm packages will be installed (automatically) using the npm client command line interface, so you must have an npm package manager. Node.js includes it by default. So, after installing Node.js, check that you have the npm client installed, by running the sollowing command in a terminal/console window:
    npm -v

     
  • Angular CLI
    To install the Angular CLI using npm: open a terminal/console window and enter the following command:
    npm install -g @angular/cli

     

Note: Node.js is only required for development. It is not required for production.

FAQ

Q: Why is Node.js required for Development?
A: To fasten development cycles. The server updates the pages automatically, without the need for extra compilation times.
Look at the npm and ng commands of this page which explain more details.