Use annotations for servlet definition property

Official Content
This documentation is valid for:
Enables the creation of web applications valid for the Servlet 3.0 or higher specification.

Values

No
Yes Default Value.

Scope

Generators: Java
Level: Generator

Description

Notes:

  • If Tomcat 7.x or higher is detected, the value of the property is Yes; otherwise, if there is a lower version of Tomcat (or it isn't installed), the value is No.
  • Servlet annotations are not compatible with versions lower than Servlet 3.0; an application generated with the property enabled will not work on an application server with lower specification support.
  • For more information, read SAC #29992.

Run-time/Design-time

This property applies only at design-time.

How to apply changes

To apply the corresponding changes when the property value is configured, execute a Rebuild All.