BlackBerry Requirements

Official Content
This documentation is valid for:

In order to use BlackBerry you have to: 

Install  JDK (version 6).
Install BlackBerry JDE 5.0. Follow instructions here.

 

If you install the JDE 5.0, then you can generate for OS 4.6.1 or OS 5.0. That setup also installs a simulator (corresponding to BlackBerry Bold 9700), so you don't need an extra one.

JDE 4.6.1, 6.0 or 7.0 are also supported, but generator's default property values may not work and you may set the corresponding ones.

JDE setup (any version) already installs some simulator too, but you can install the one that best suites your needs and configure the correspondinggenerator's property values.

More information

BlackBerry Smart Devices